This article is related to all MeshForce products. (M1, M3 and M3 Dot)


There are several reasons may cause this, to improve your connection quality, please view this article.

In best circumstance the WiFi can reach 70%-80% of marked speed rate, consider distance, network usage and remote server connection, it may be lower.

If your speed is far less than that, 

  • Band & Channel: This is a major reason. Every time your device join the WiFi, it will be assigned a band & channel in random. If your mobile joined a crowded channel, the speed may be decline. Try to restart the mesh points / dots, reconnect the WiFi. (When you reboot, please reboot all mesh points/dots at one time, then plug again together.)
  • Mobile Device Compatibility: Check if your mobile device supports 5 GHz WiFi, if not, speed may be lower. --Try to restart all mesh points and connect to WiFi again.
  • Settings: Turn off "Capacity oriented mode" in My Mesh app. Under this mode the speed will be limited to ensure more connections. Then unplug all mesh points, restart them after 5-10 minutes until the motherboard is completely cool down. Forget/Ignore the WiFi name on your mobile/PC, join the SSID again.
  • Consider traffic, if there is anyone using downloading or HD video streaming.
  • Distance: Get closer to the main mesh point and reconnect the WiFi on your mobile device.
  • Interference: Check if fridge, microwave oven is nearby, this may affect the speed as well.

Ethernet connection is more stable than wireless.
On MeshForce M1, the max wired speed rate is 100Mbps. If your Internet plan is higher than 100Mbps, the ethernet performance will reach its hard line limit. 

On MeshForce M3, the max wired speed rate is 1Gbps.

Did this answer your question?